Windows 10 keeps waking up from sleep

My Windows 10 desktop PC keeps waking up despite putting it into sleep mode. It’s pretty annoying as I prefer to just wake it up than wait for it to boot and login.

Has anyone else had this? What’s the fix?
thanks

Hi @davenet, welcome to Computer Forums :wave:

It’s a bit strange that this is happening - is there any chance the computer is plugged in via ethernet?

Have you added or removed any hardware recently or bought anything new such as a mouse?

Has this always been a problem or has it recently started?

thanks for getting back to me

Only thing that has changed is I got a new router from my ISP

I use it on ethernet via powerline adapter to my router

To help troubleshoot this issue could you open an administrator command prompt (type cmd on the start menu /search box, right click and choose run as administrator)

Run the following command:
powercfg -devicequery wake_armed

and paste the output here?

Hi thanks for getting back to me!

I just get this on that command:
C:\Windows\system32> powercfg -devicequery wake_armed
NONE

Okay that’s odd.

Does the computer have the option to connect via wifi rather than ethernet and if so are you able to try it on wifi for a couple of days to confirm if it’s the ethernet connection/network card causing the issue?

I’ve tried just using wifi for a few days and it seems to have fixed it!!

is there any way I can continue to use ethernet with my PC though is there a setting I can tweak or something?

Try this. Note I don’t use a Windows machine myself at home so this is from memory so steps may be slightly different:

  • Right click Start Menu.
  • Go to Device Manager.
  • Find your ethernet adapter (normally it will be realtek/intel/atheros/etc Gigabit LAN or similar)
  • Right click on it > properties.
  • Go to Power Management
  • Untick wake on magic packet / allow this device to wake up computer
  • Save settings, reboot, see if the issue has gone away! :slight_smile:

IT WORKED!!!

Thanks for helping me :slight_smile: