• Computer Forums is where you'll find free PC help, tech support & discussion of technology.

    From Windows errors to which smartphone to buy, home automation to internet connections, we're here for you.

    Registration is quick, easy and entirely free, and lets you post your computer questions, receive answers from experts and fully take part in our site.

    Ready to jump in? Register now

Windows 10 keeps waking up from sleep

Status
Not open for further replies.
A

anon42955572

Guest
My Windows 10 desktop PC keeps waking up despite putting it into sleep mode. It’s pretty annoying as I prefer to just wake it up than wait for it to boot and login.

Has anyone else had this? What’s the fix?
thanks
 

root

Administrator
Staff member
Hi @davenet, welcome to Computer Forums 👋

It’s a bit strange that this is happening - is there any chance the computer is plugged in via ethernet?

Have you added or removed any hardware recently or bought anything new such as a mouse?

Has this always been a problem or has it recently started?
 
A

anon42955572

Guest
thanks for getting back to me

Only thing that has changed is I got a new router from my ISP

I use it on ethernet via powerline adapter to my router
 

Philtrum

Member
To help troubleshoot this issue could you open an administrator command prompt (type cmd on the start menu /search box, right click and choose run as administrator)

Run the following command:
powercfg -devicequery wake_armed

and paste the output here?
 
A

anon42955572

Guest
Hi thanks for getting back to me!

I just get this on that command:
C:\Windows\system32> powercfg -devicequery wake_armed
NONE
 

Philtrum

Member
Okay that’s odd.

Does the computer have the option to connect via wifi rather than ethernet and if so are you able to try it on wifi for a couple of days to confirm if it’s the ethernet connection/network card causing the issue?
 
A

anon42955572

Guest
I’ve tried just using wifi for a few days and it seems to have fixed it!!

is there any way I can continue to use ethernet with my PC though is there a setting I can tweak or something?
 

Philtrum

Member
Try this. Note I don’t use a Windows machine myself at home so this is from memory so steps may be slightly different:
  • Right click Start Menu.
  • Go to Device Manager.
  • Find your ethernet adapter (normally it will be realtek/intel/atheros/etc Gigabit LAN or similar)
  • Right click on it > properties.
  • Go to Power Management
  • Untick wake on magic packet / allow this device to wake up computer
  • Save settings, reboot, see if the issue has gone away! 🙂
 
Last edited:
Status
Not open for further replies.
Top