• Computer Forums is where you'll find free PC help, tech support & discussion of technology.

    From Windows errors to which smartphone to buy, home automation to internet connections, we're here for you.

    Registration is quick, easy and entirely free, and lets you post your computer questions, receive answers from experts and fully take part in our site.

    Ready to jump in? Register now

No file history

Rossandjet

New member
Hi All, I have decided to try and use Windows 10 backup for my main backup to an external hard drive, but when I try to use it, I am getting an error message and so far I have not been able to turn it on. Can you help please:

The message: Could not enable file history. Access denied.

I am using windows 10 home 21H1
 

root

Administrator
Staff member
Hmm, this is strange.

The hard drive you’re using - is it one you have used before? Or is it new, or recently formatted?
 

Rossandjet

New member
I have tried 4 different ones 1 a 250GB SSB and two other externals with data I have also formatted an 8GB USB Cruzer all got the same result.
 

root

Administrator
Staff member
Have you applied any sort of system tweaks? Or any security programs running on your machine?
 

root

Administrator
Staff member
I look forward to finding out what’s caused this! A bit of further research online points towards possibly a few services being disabled but let’s see what MS say.
 

Rossandjet

New member
Well, after 5 hours on and off the phone to a Microsoft chap to no avail. Finally, he wanted to do a clean install, and to be honest, I had just about had enough. I told him I was not going to do it and if I just used a downloaded software program to do my backing up, it would not matter one bit if the file history was working or not. Although not pleased he had to accept it.
 

root

Administrator
Staff member
Sometimes the best solution is the easiest.

With that said I will try to have a dig around the internet at some point to see if I can find some helpful links to add to this post in case anyone else comes across this issue in the future.
 
Top