• Computer Forums is where you'll find free PC help, tech support & discussion of technology.

    From Windows errors to which smartphone to buy, home automation to internet connections, we're here for you.

    Registration is quick, easy and entirely free, and lets you post your computer questions, receive answers from experts and fully take part in our site.

    Ready to jump in? Register now

Laptop screen black after power on or opening

A

anon96701537

Guest
Hi

I have a pretty new Acer Aspire 5

I am finding that -only sometimes- when I switch my laptop on or open the lid the screen stays off

The screen is totally black. Only when I try holding the power button for ages does it come back on

I consider myself quite computer savvy but I have not been able to work out the solution to this one

Is there any fix? any ideas?

Thanks
Cairis
 

root

Administrator
Staff member
Hey @anon96701537, welcome to Computer Forums 🙂

Could you let us know what you have tried so far?

Some things to try if you haven’t already might include disabling hybrid sleep / fast startup and checking your machine has the latest BIOS / UEFI updates - are you running on Windows 10?
 
Last edited by a moderator:

Philtrum

Member
How often do you get the blank screen issue? Is it occuring when you are running on battery, plugged in or both?

Have you checked the brightness is all the way up?
 
A

anon96701537

Guest
I have done the updates

how do I turn off ‘hybrid sleep / fast startup’
 

root

Administrator
Staff member
Here’s how to do it. It’s quite a few steps but if you do them one by one it should be manageable and will hopefully resolve the blank laptop screen issue for you:

Click start and type ‘power’ in or use the taskbar search if you have this enabled.

On the right choose ‘additional power settings’.

Choose ‘change plan settings’ then ‘change advanced power settings’.

Under the sleep option on the list, set allow hybrid sleep to off for both AC and batteries.

Come out of the plan settings and on the left of the power options window go to choose what the power buttons do. Click change settings that are currently unavailable, then uncheck turn on fast startup.

Save the changes, close all windows and reboot your computer.

This should hopefully fix the problem for you at the expense of a few seconds extra boot time 🙂
 
Last edited by a moderator:
A

anon96701537

Guest
OMG this seems to have worked! have tested over the past couple of days and haven’t had the problem since making the changes! thank you so much 🙂
 
Top