• Computer Forums is where you'll find free PC help, tech support & discussion of technology.

    From Windows errors to which smartphone to buy, home automation to internet connections, we're here for you.

    Registration is quick, easy and entirely free, and lets you post your computer questions, receive answers from experts and fully take part in our site.

    Ready to jump in? Register now

Wifi Not Showing in Taskbar > Internet Access

Status
Not open for further replies.

yuckfoo

New member
I have an intermittent problem. Under “Internet access” located at the bottom right of my task bar I see “Airplane Mode” option but nothing else. I have an ethernet cabled connection that works, but none of the wifi connections in my area show up including my own. I have used another device to confirm that the problem is with this laptop and not my wifi.

My laptop is a Toshiba Satellite C55-C5270 (on a side note that model number doesn’t exist according to Toshiba 😛 )

This problem occurred yesterday then corrected itself. It was fine this morning, then it happened again. What could be the cause and what can I try to fix it? Is there a way I can test the hardware? I tried many things yesterday to fix it and nothing works. I am suspecting hardware. But I am NOT an expert. Don’t let my comment steer you. Thanks!
 

yuckfoo

New member
Quick addition: I see “We couldn’t find wireless devices on this PC” error message in red text when I go to Settings > Wireless Devices.
 
Last edited:

root

Administrator
Staff member
Hi @yuckfoo, welcome to Computer Forums 👋

I would be interested to hear what you have tried so far, and whether your laptop is still under warranty? The fact that it seems to be intermittent points my thinking in the direction that as you suspect it might be hardware.

If you look in Device Manager (right click Start, select Device Manager if you’re on Windows 10) if you look under network adapters do you see your wifi device listed here?

Have you done any big Windows updates recently around the time the problem started?
 
Last edited by a moderator:

yuckfoo

New member
My memory is terrible. I tried a bunch of stuff. I was even in a Microsoft help thing that I got started from my computer. They had me do a bunch of stuff then basically blew me off at the end. lol. I should clarify what I mean by “intermittent.” Basically it happened yesterday, fixed itself somehow, then happened again this morning. That’s the history of it so far. In Device Manager there is nothing under “wifi” but under “network adapters” there is “Realtek PCIe Family Controller” and 8 “miniports” in the nested list. I have already tried updating the drivers for those items. I don’t remember if I did any Windows updates. I may have. The laptop is 4 or 5 years old, not under warranty.
 
Last edited:

root

Administrator
Staff member
No worries if you don’t remember, I generally take the same approach of trying everything until something works…

If device manager is not listing the wifi card at all my gut feeling is that it is hardware. Often wifi cards can be replaced on laptops particularly older ones without dramas, but it normally involves taking the entire thing apart to get access to it. Your PCIe family controller is likely to be the ethernet and the WAN Miniports are virtual devices that are used by Bluetooth so it does not appear that Windows is ‘seeing’ your wifi.

When you looked in device manager did you see any warning triangles / unknown devices at all? If not I would put my money on the wifi being toast.

The cheaper/easier way to fix it would be to sacrifice one of your USB ports for a Wifi dongle - they can be found as absolutely tiny devices now that essentially sit in the port flush with the laptop so not too much of a hassle.

One final thing you could consider doing to rule the software out completely is to reinstall Windows 10. Ensure you back up your data first and any software licences etc.

Start > Settings > Updates and security > Recovery and choose Reset this PC.

I could provide a few less drastic software fixes that might do the trick but chances are you probably have either already tried them or they would probably be a waste of time sadly.
 

yuckfoo

New member
I’ve taken laptops apart many times in my life. I’m no expert but I’m tenacious enough to tinker with things till I figure out how to fix them. Any advice on discovering exactly what new hardware I should buy? I don’t want the dongle fix…I teach guitar online and use all my ports for mouse, camera and microphones.
 

root

Administrator
Staff member
The setting advising it’s not seeing any wireless devices does seem to confirm the theory that Windows is no longer seeing the hardware.

I’m probably teaching you to suck eggs here but looking online further suggests it might be worth using fn+f12 or just F12 to see if it’s not just a wifi switch being disabled according to Toshiba’s manual for your non-existant laptop 😉 Pretty sure it’s not it but always worth sanity checking the small stuff.

Otherwise I have found a video on how to do the procedure to change the wifi card:


One thing the video does not make clear is what to order as the video producer wants you to buy from them at an inflated price.

Searching online suggests that the Wifi card model is a Atheros C204N3. It’s worth replacing like for like as some manufacturers will have an ‘approved hardware list’. Assuming you are in the USA - eBay shows them for less than $10 or you might have a computer parts nearby that will have one in stock.
 
Last edited by a moderator:

yuckfoo

New member
Thanks so much for the part number! I have tried the F12 previously. Since they don’t cost very much I will buy one and see if that fixes things. Thanks again.
 

root

Administrator
Staff member
Great stuff - having an older laptop has these advantages - my daily driver is an 8 year old ThinkPad where I’ve changed pretty much every part at this point but I’m a huge believer in cutting down on ewaste.

Let us know how it goes 🙂
 

yuckfoo

New member
Oh… I just learned that “Network Reset” is a thing. It’s a fix for stuck airplane mode. It resets all network adapters. It restarts PC…I’ll let you know if it fixes it.
 

root

Administrator
Staff member
Hmmmm - it is curious that airplane mode is stuck on. To my best knowledge Windows would not show airplane mode for a computer with a missing WiFi card so it might be worth trying to disable or restart the the Radio Management Service that controls airplane mode - press windows key + R, type services.msc and hit enter.

Find the service and try to disable or restart it.
 

yuckfoo

New member
I had some luck, but I’m in no way confident that what I did was the reason for it coming back. I tried these again:

Type netsh winsock reset and selectEnter.
Type netsh int ip reset and select Enter.
Type ipconfig /release and select Enter.
Type ipconfig /renew and select Enter.
Type ipconfig /flushdns and select Enter.

I think I was on the second one and after I restarted on that step the wifi came back. But I’ll see what tomorrow brings. XD Thanks for your interest in helping me. It’s much appreciated. It can be stressful trying to fix PC stuff and it’s always easier when someone is on your side.
 
Last edited:

root

Administrator
Staff member
This is a very strange one indeed - ipconfig release/renew shouldn’t affect the wireless card appearing in device manager!

A couple of other things I would suggest trying at this point just in case it’s some bizarre Windows 10 issue:

1 - a system restore back to a time where the problem wasn’t happening
2 - a system file check - it should spot any corrupted Windows files and repair them.
Run sfc /scannow in an admin command prompt. Let it run (anywhere from 5 minutes to up to an hour) and reboot once it’s complete - it will tell you if it finds any corrupted files.

I’m always interested in helping people and know how frustrating these things can be sometimes - weird stuff like this is always interesting to try to get to the bottom of. I’ve never seen a problem quite like this one so would love to know what the final fix is!
 
Status
Not open for further replies.
Top